Lightroom Sucks: An Open Letter to Adobe

Story 202802359

“Panic on the streets of London, panic on the streets of Birmingham, I wonder to myself, could life ever be sane again?” You’d be forgiven for thinking The Smiths were singing about wedding photographers mid-summer running around the streets in a naked hysteria after they’ve just installed the latest Lightroom update.

Adobe, I hope you read this because it seems like for too long now you’ve ignored the issues and released update after update that actually made things worse, NOT better!

This open letter is not a plea for you to up your game — it’s a demand. You owe it to all the subscribers that have shown great loyalty to you for such a long time.

“Ooh look I have 6 weddings in the queue, I’m a little stressed and wedding season is taking its toll, but it’s OK as I have three days solid booked out to make a dent in things. Ok, I’ll just load up Lightroom…” And this is where a whole world of frustration, irritation and wanting to walk into traffic begins. For while we may have time finally to catch up on some editing, Lightroom generally decides to throw a spanner or ten in the works!

Now I want to get one thing very straight here, Lightroom is a wonderful piece of software… when it works properly. It’s revolutionized the way wedding photographers process work, making it easier and more convenient.

Why oh why then does Adobe continue to release updates that seem to make it almost unusable at times? At best these days my experience of using it is sub-par, a whole catalog of issues are present at all times, and of course, I’m not the only one who has this experience. So Adobe for the love of God will you PLEASE sort it out!

I hear time and time again from people involved in their beta testing that Lightroom needs to be rebuilt rather than updated and that Adobe is aware of ‘bugs’ and trying to resolve them. Well, quite frankly, that isn’t good enough! How many hundreds of thousands of wedding photographers use Lightroom and pay their subscription to CC? It’s impossible to know, but MORE than enough to warrant Adobe giving us more back — a hell of a lot more.

There’s also a stark warning here for Adobe: you rest on your laurels and eventually someone else will release something and everyone will jump ship. You only have to see how many people have switched to Sony from Canon or Nikon to understand that brand loyalty doesn’t mean anything if something shinier, better, and more appealing comes along. It will happen one day to you too, Adobe, if you continue to be so complacent and not give us the software we want and deserve.

Minimum System Requirements

I’m going to list some of the issues I face using Adobe Lightroom in a moment and then a load that other photographers have also shared with me. Firstly though I want to examine what the recommended system specifications by Adobe are because it makes for surprising reading!

Source: https://helpx.adobe.com/lightroom/system-requirements.html

So a minimum 4GB RAM and 12GB recommended. Yes, that’s right: a MINIMUM of 4GB RAM. So what Adobe is saying is that you CAN run Lightroom on a machine with as little as 4GB of RAM, really?

12GB is the recommended… how old are these specs? I think that’s one of the things that irks me about Adobe’s approach to their software packages. If they said ‘hey it’s a minimum of 16GB RAM but we’d recommend 32GB’ it would help us make informed decisions when spending $2,500 on our editing machines.

If you use Lightroom as your main memory-intensive application then you could easily be lulled into thinking that a cheaper spec machine with less RAM is fine, when it really wouldn’t be. Adobe do you really think Lightroom CC can run fine on a machine with 4GB of RAM? Erm, no!

I Have Issues

I tried to write down all the issues I face using Lightroom, some will no doubt have slipped my mind, but I think the list in itself is pretty comprehensive and includes the following:

– Flicking between images even with Smart Previews enabled takes too long, there’s a pause while it renders. Ok, this is one everyone pretty much has, but it seems to be getting worse!

– Preset not showing as being applied until I make a change. It just shows the straight-out-of-camera version until I change the exposure or crop/rotate and then BINGO, there’s the preset. This is an intermittent issue, sometimes it’s there, sometimes not… however, when it’s there it affects several hundred photos at a time. It’s a confusing and irritating problem. It seems to occur if I edit for a few hours, like Lightroom is tired and can’t be arsed anymore, keen to get home for its dinner and watch The Walking Dead.

– Trying to crop or rotate anything involves a lag similar to my 3-year-old when I ask him to do pretty much anything. This is a new issue (in LR, not with my 3-year-old — that’s always been there with him), and it’s very annoying, Adobe!

– In full-screen mode the left menu panel used to pop out when you hovered over it, it no longer does this, except last Tuesday when it DID, only to revert back to not doing so by Wednesday morning. Apart from that delightful Tuesday, I have to click to open it and click to close it again.

– Then there’s the curious issue for whenever a new update is available, my current version either suddenly runs super sloooooow or stops working altogether, forcing me to update to the latest one. Now I’m not suggesting Adobe is somehow sending a sneaky patch to break my existing version so I HAVE to update, but if they are it’s REALLY annoying and happens so often it’s hard to not feel a little suspicious about.

– Let’s not forget the issue where you are using a catalog and wish to open a different one, which results in the first catalog successfully closing, but Lightroom just sitting there and not responding until you either force quit (or sometimes actually have to switch off the machine as it won’t force quit), or after several minutes it finally decides to respond again and open the new catalogue.

– Photoshop opens weird about 75% of the time. So if you’re like me and like to add an extra bit of sharpening to portraits or clone out bird poop from the fence where the couple is standing etc, you’ll Command E to open Photoshop. It’s great you can open PS from LR, edit, save and it appears back in LR as a .tiff. Bravo Adobe, that is one nifty function! Except when it opens like this three-quarters of the time.

Apologies for the portrait, clearly not keeping it real at this point of the wedding – this was just the only time I remembered to screen shot the issue

I haven’t cropped anything from the PS window here, that’s how it opens most of the time. To make it usable I have had to click ‘view’ and then ‘full screen with menu bar’ so many times recently that I’m starting to get RSI (and RAGE) from it.

Incidentally, if anyone else is suffering the same issue, I found a quick way to make it display correctly. I stumbled upon by pure accident as I tried to ALT+TAB back to Lightroom. My RSI finger completely unaware of what it should be doing pressed the desk instead of the ALT key by mistake, thus showing me that pressing TAB alone changes the view mode and makes it normal again… hallelujah!

There are other issues too. It’s slow. It lags a lot. If you import images to a new catalog you have to close LR after it’s imported them and reopen again or it runs slower than me in a school sports day father’s 100-meter race. Oh, and don’t forget to close the histogram as having a tiny graph at the top of your screen makes LR wheeze with pain at the pure exertion of displaying it.

While all these things might not seem much, they impact my day to day work, it’s an inconvenience I could do without, and as I’m paying regularly for the use of this software I’d damn well like it to work properly! It costs me time and frustrates the living daylights out of me.

System of a Down(beat Photographer)

I appreciate I don’t have a monster of a machine, but it is actually a higher spec than Adobe recommends. So going on their information, supplied in order for us to make informed purchases, I shouldn’t be having any issues, certainly not from a machine performance point-of-view anyway.

Problems in the Community

I asked the Facebook community that I run (please join us on there if you aren’t already a member) what issues people were facing and what spec machines they were using because as with most things in life, you worry that it’s maybe just you. It turns out I’m not alone!

Rob Georgeson [Intel Core i5 / 16GB RAM / 1GB NVIDIA Graphics Card / 120GB SSD HD]: “My pc definitely seems to be working harder just to do basic editing. It used to be a breeze but now I can hear the fans running at full speed trying to get my computer to chill the f**k out”.

Andrew Bowness & Esther Wild [Windows 10 / Intel i7-6700 @ 3.4ghz / 16GB RAM / SSD / 6GB Nvidia Graphics Card, Mac OS High Sierra (10.13.6) / Intel Core i5 / 8GB RAM / Radeon Pro 2048 Graphics Card] also are having the same issue, Andrew’s being so bad ‘I put music on to drown it out.’ Esther also has issues with it hanging and getting the spinning wheel of doom.

Michael Newington Gray & Paul Marbrook [Mac OS High Sierra / Intel Core i7 / 16GB RAM / AMD Radeon R9 Graphics Card, MAC OS High Sierra / Intel Core i5 / 24GB RAM / NVIDIA GeForce GT Graphics Card]: When flicking between images in Develop module the images aren’t loading / going sharp until I zoom in and out.

Oli Kelly [Windows 10 / Intel Core i5 / 8GB RAM / GeForce GTX 1050 Graphics Card]: When I’m doing brush work it can lag out so badly and make the mouse skip over the image like it’s buffering. When flicking through images it can pixelate the original raw for sometimes 10 seconds until it remembers what I have done to the image and then shows my edit.

Denver Aubrey [Mac OS High Sierra / Intel Core i5 / 24GB RAM / AMD Radeon R9 Graphics Card]: Everything seems to lag despite massive amounts of ram and a decent spec iMac. Drag a slider, let go, wait for half a second or a whole second and then see the effect. Maybe. Just updated LR CC classic today to the latest version. Now LR opens for about 2 mins and then unexpectedly quits.

Ally Hedayati [Mac OS High Sierra / Intel Core i7 / 20GB RAM / AMD Radeon HD 1024MB Graphics Card]: When I want to do some external editing in PS from LR, PS revets it to SRGB – making a black and white image colour for instance. Even though I have “turn to SRGB” unticked.

Jade Eleanor Evans [Mac OS High Sierra / Macbook Pro 15″ 2017 / Intel Core i7 / 16GB RAM / Radeon Pro 560 4GB Graphics Card]: Too slow, not sure what on earth it’s doing but I have one of the new macs (2017) and it gets so hot it actually leaves red marks on my legs when I have it on my lap. Even when its used on a desk it still gets hot and the fans sound louder than my hair dryer! Also for some unknown reason when I export and choose ‘resize to fit, longe edge’ I type in whatever for the long edge and that ends up being the shorter edge… No-one has any idea why it does this! So if I type in 2048 for the long edge (I mostly shoot landscape), they export at 3072 x 2048 making the shorter edge 2048 (yes I am definitely clicking ‘long edge’ not ‘shorter edge),

Jamie Ousby [Mac OS Sierra / Intel Core i7 / 16GB RAM / NVIDIA GeForce GT Graphics Card]: Lightroom doesn’t export some exposure changes for around 10 x images when exporting a wedding of 800+ images. Go to the image in question and adjust the exposure slider up and it accepts it. Switch to full screen to take a look and it shows the correct exposure for a split second and then flashes back to the “as shot” exposure. No matter what I do when exporting this image it will not accept the exposure setting.

A bride on her wedding day still traumatised after installing a new Lightroom update the day before. Image by Andrew Billington

What is your current relationship with Lightroom?

The Other Side of the Coin

Not everyone we spoke to experienced issues with Lightroom. In fact, some found it to work perfectly. Their specs were similar to those above with one large exception – their memory ranged between 32GB and 64GB RAM. So is this the solution?

Adobe, we’d love for you to clarify just what is going on here. Is it just you’ve told us incorrect information when stating the software should run perfectly on 12GB RAM (hell, it should still run ok on 4GB according to your minimum specifications)? Or, as I’ve been told many times by your beta testers, is the software inherently broken and does it need rebuilding from the ground up? If that’s the case, is this going to happen, and if so when?

Yours Sincerely

I did consider signing off this open letter with ‘yours faithfully’, but to be completely honest I’m only faithful to you because there aren’t any serious alternatives on the market at the moment. Yes, Capture One can do a similar job, but from what I’ve heard it’s not quite enough to make the leap over.

So I’ll stick with you until something better comes along… or you buck up your ideas enough to actually make this more than a marriage of necessity. Over to you, Adobe!


About the author: Andy Hudson is the co-founder of Photographers Keeping it Real , a website, award, and podcast for documentary wedding photographers. The opinions expressed in this article are solely those of the authors. You can find more content by Hudson and connect with him on his website and Facebook group . This article was also published here .


Image credits: Header illustration based on photo by Mwangi Gatheca

You may also like...